Vimexx Facebook

Onderwerp: Magento 2 niet compatible met composer 2.0

11-12-2020 13:10

Composer is geupdate naar 2.0, echter is Magento 2 niet compatible hiermee. Magento 2 heeft composer 1 nodig. Is er een mogelijkheid om deze update terug te draaien?

26-12-2020 12:20
#2883

Zelfde probleem (voorlopig ook) bij Drupal 8.9.10.  Poging versie 1 weer te installeren via  'composer self-update --1' geeft foutmelding: 'Composer update failed: "/usr/local/bin/composer" could not be written.   rename(/usr/local/bin/composer): failed to open stream: Permission denied' .  Kan ik hier zelf iets aan doen (map /usr/local/bin/composer kon ik niet vinden?)

27-12-2020 11:33
#2884

Oplossing was in mijn geval: deze link :

"I have solved it already. Because I have a shared hosting, I cannot change the composer version, but what I should do to use composer version 1 is just adding "v1". So in stead of composer update, I am using now composerv1 update."