Vimexx Facebook

Onderwerp:

Forceeer mijn website naar https SSL

Naam: Karla M

Titel: Member

Geplaatst op 21-11-2016 09:02

Hallo, ik heb voor mijn wordpress website de aanwijzingen gevolgd op https://www.vimexx.nl/help/forceer-mijn-website-na...

Deze plugin geactiveerd: https://nl.wordpress.org/plugins/really-simple-ssl...
De website wordt dan niet meer gevonden. Het lijkt erop dat ik de bestanden moet verplaatsen naar de map private_html. Nu staan ze in een submap op public_html

Klopt dat? De aanwijzingen suggereren dat het eenvoudiger kan. Graag advies hoe verder te gaan.

Datum 21-11-2016 09:02:57

Naam: Naud J

Titel: Member

Geplaatst op 21-11-2016 16:39

Beste Karla,

Dank voor je post op ons forum.

Als je via "domain setup" in DirectAdmin klikt op je domeinnaam en vervolgens het onderste bolletje selecteert (nu staat het bovenste bolletje geselecteerd) en dit vervolgens opslaat dan maakt het systeem een symbolische link aan waardoor de private_html en public_html dezelfde content vertonen. Hierna zou je website zichtbaar moeten worden!

Hopend hiermee je vraag beantwoord te hebben. Mochten er nog vragen zijn dan vernemen we die graag!

Datum 21-11-2016 16:39:11

Naam: Karla M

Titel: Member

Geplaatst op 21-11-2016 19:58

Dank je wel Naud, dat loste het inderdaad op. Heel eenvoudig dus. Maar als ik nu op de site kijk, zie ik in Firefox de adresbalk een slotje en een oranje uitroepteken en de melding als ik daarover heen ga: deze website verstrekt geen identiteitsinformatie. Ik zie ook een uitroepteken. Als ik daar op klik, komt er een popupscherm met: verbinding is niet beveiligd. Onderdelen van deze pagina zijn niet beveiligd, (zoals afbeeldingen). Toestemmingen: u hebt deze website geen speciale toestemmingen gegeven. Het gaat om deze site: https://henkdecourtonderwater.nl/ Is dat alles normaal?

Datum 21-11-2016 19:58:34 | Gewijzigd op 2016-12-14 05:52:59

Naam: Naud J

Titel: Member

Geplaatst op 21-11-2016 20:35

Beste Karla,

Dank voor je reactie.

Dat zie ik inderdaad ook op bijvoorbeeld: https://henkdecourtonderwater.nl/reacties-welkom/. In je script worden dan afbeeldingen of andere content geopend over http:// ipv https://. Je kan dit oplossen door in de code overal van http:// > https:// neer te plaatsen, zodoende wordt alles over https:// geladen. Als je content laad vanaf externe sites dan kan het zijn dat zij geen beveiligde connecties ondersteunen, dan kan je dat helaas niet verhelpen.

Hopend hiermee je vraag beantwoord te hebben. Mochten er nog vragen zijn dan vernemen we die graag!

Datum 21-11-2016 20:35:31 | Gewijzigd op 2018-05-07 10:21:14

Naam: Karla M

Titel: Member

Geplaatst op 21-11-2016 21:32

Maar hoe zit het dan op https://henkdecourtonderwater.nl/zijn-werk/schilde...? Deze pagina bevat alleen maar plaatjes?
En inderdaad wat wordpress scripts met ogelijke http inhoud zoals: hieronder waarin dit wordt aangeroepen: http://www.w3.org/TR/SVG11/feature#Image","1.1"

https://henkdecourtonderwater.nl/henk/wp-includes/js/wp-emoji-release.min.js,

en

contact-form-7/includes/js/jquery.form.min.js bevat:

* Examples and documentation at: http://malsup.com/jquery/form/

De foobox plugin:

fooboxV2/js/foobox.min.js

bevat: * @link http://fooplugins.com/plugins/foobox-jquery en Powered by ",url:"http://fooplugins.com/plugins/foobox/

Ook google analytics com roept iets aan: http://www.google-analytics.com

Kan dat het allemaal verstoren?

Firefox geeft nog deze toelichting: https://support.mozilla.org/nl/kb/blokkering-gemen... met de suggestie om dit goed op te lossen. Kan ik nog meer doen? Ik wil die plugins niet kwijt.. Het komt ook echt op alle pagina's voor.

Datum 21-11-2016 21:32:18 | Gewijzigd op 2018-05-29 22:01:15

Naam: Marianne G

Titel: Member

Geplaatst op 23-11-2016 15:00

Beste Karla,

Als je deze plaatjes en scripts dus over httpS:// laat laden, dan zal de melding verdwijnen. Zodra je website op https aangeroepen word, moeten alle bronnen helaas ook over https opgehaald worden, anders zijn er onbeveiligde elementen in je website en voldoet https niet!

Datum 23-11-2016 15:00:54

Naam: Karla M

Titel: Member

Geplaatst op 26-11-2016 13:22

Beste Marianne,
Dank je wel; het ging uiteindelijk slechts om één plaatje, het plaatje in de header, dat blijkbaar een http-aanroep kreeg vanuit mijn Suffusion thema. Ik heb het opnieuw geupload en nu krijg ik een groen slotje in Firefox. Om dit foutje te ontdekken gebruikte ik Google Chrome. Daar gaf hij ook die melding, maar daar kon je klikken op het driehoekje en kreeg ik iets meer aanwijzingen.

Tevreden dus, probeerde ik het net met een andere site: https://1energiezuinighuis.nl/
Ik deed, naar mijn gevoel hetzelfde:
plugin installeren, activeren en nog een keer drukken op de knop activeer SSL
Bij de instellingen: ook een vinkje gezet naast: Stop editing the .htaccess file; dit lijkt nodig omdat de website in een submap staat. Dat gold ook voor mijn vorige site.

Nu krijg ik deze melding en echt een flink kruis: Uw verbinding is niet beveiligd

Bij onderzoek via Google Chrome lijkt het te gaan om een:
Certificate Error

There are issues with the site's certificate chain (net::ERR_CERT_COMMON_NAME_INVALID).

Heeft u enig idee?

Datum 26-11-2016 13:22:12 | Gewijzigd op 2018-05-29 22:01:37

Naam: Rick B

Titel: Member

Geplaatst op 27-11-2016 19:04

Hi Karla,

Die melding wordt veroorzaakt, doordat de domeinnaam in het certificaat niet gelijk is aan gebruikte domeinnaam.
Als je een nieuw certificaat aanvraagt, moet dit opgelost zijn (ervan uitgaande dat je een (gratis) Let's Encrypt certificaat wilt gebruiken): https://www.vimexx.nl/help/gratis-lets-encrypt-ssl...

Ben benieuwd of je het nu lukt.

Groeten,

Rick

Datum 27-11-2016 19:04:09

Naam: Karla M

Titel: Member

Geplaatst op 28-11-2016 13:37

Ja, bedankt, dat was het!

Datum 28-11-2016 13:37:28 | Gewijzigd op 2016-12-14 05:52:59

Naam: Marianne G

Titel: Member

Geplaatst op 29-11-2016 12:43

Graag gedaan! Fijn dat het werkt Karla!

Datum 29-11-2016 12:43:03