Vimexx Facebook

Onderwerp:

403-foutmelding bij bezoeken website

Naam: Dennis H

Titel: Member

Geplaatst op 13-09-2016 21:22

Beste allemaal,

Ik heb zojuist geprobeerd om mijn website acnop.nl om te zetten naar HTTPS. Dit mislukte echter jammerlijk. Toen ik SSL had geactiveerd en een .htaccess-bestand in de map public_html had gedaan met de inhoud zoals beschreven staat in https://www.vimexx.nl/help/forceer-mijn-website-na... en de site opende, kreeg ik een melding dat ik een index.html in de map private_html moest doen. Dit vond ik vreemd, ik deed alle bestanden altijd in public_html, maar ik deed het toch maar. Vervolgens opende ik mijn site weer en was het wel een https-verbinding, maar zonder groen slotje. Nu probeerde ik maar om de index.html en de .htaccess weer te verwijderen, maar nu zit ik met een certificaatfout en een 403-error als ik mijn site probeer te openen.

Ik wil dat mijn site naar public_html verwijst via een https-verbinding met een groen slotje. Hoe doe ik dit?

Met vriendelijke groeten,

Dennis Holierhoek

Datum 13-09-2016 21:22:45

Naam: Naud J

Titel: Member

Geplaatst op 14-09-2016 10:53

Beste Dennis,

Dank voor je post op het forum.

Je kan alle bestanden gewoon uploaden in de public_html map. Zodra je dat gedaan hebt dan ga je naar "domain setup" in DirectAdmin, vink je SSL aan en kies je het onderste bolletje. Zodoende maak je een symlink waardoor alles goed geladen gaat worden straks.

Daarna plaats je de code voor het forceren in je .htaccess (let op bij Wordpress gebruikers dien je een andere manier te gebruiken, dit staat ook in de handleiding beschreven) en word je site geforceerd naar HTTPS. Als het goed is moet het daarna werken. Mocht dit niet het geval zijn dan horen we dat graag zodat we verder kunnen kijken wat er aan de hand is!

Datum 14-09-2016 10:53:29

Naam: Dennis H

Titel: Member

Geplaatst op 14-09-2016 14:11

Beste Naud,

Ik heb dit zojuist gedaan, maar het werkt niet. Ik krijg de http-site als ik mijn adres intyp. Ook heb ik het probleem dat ik bij de eerste keer opnieuw laden van de website een 500 Internal Server Error open. Dit herhaalt zich telkens wanneer ik de site opnieuw open, dus de eerste keer openen gaat goed, daarna verversen gaat fout, vervolgens weer verversen gaat dan weer goed.

Wat moet ik nu doen?

Met vriendelijke groeten,

Dennis Holierhoek
Datum 14-09-2016 14:11:23 | Gewijzigd op 2016-12-14 05:52:59

Naam: Naud J

Titel: Member

Geplaatst op 14-09-2016 16:02

Beste Dennis,

Dank voor je reactie.

Zou je kunnen aangeven om welk domein het gaat. Mocht je dit liever niet publiekelijk mededelen dan kan je een ticket openen via het klantenpaneel of een chatsessie starten.

Daarnaast kan je voor de 500 errors de error logs raadplegen: https://www.vimexx.nl/help/hoe-los-ik-internal-ser....

Hoor graag van je!

Datum 14-09-2016 16:02:26

Naam: Dennis H

Titel: Member

Geplaatst op 14-09-2016 17:34

Beste Naud,

Mijn domein is acnop.nl .

Met vriendelijke groeten,

Dennis Holierhoek

Datum 14-09-2016 17:34:21

Naam: Naud J

Titel: Member

Geplaatst op 14-09-2016 18:02

Beste Dennis,

Dank voor je reactie.

Er stond een typfout in je .htaccess bestand. Je site werkt nu over HTTPS.

Mochten we nog iets voor je kunnen betekenen dan vernemen we dat graag!

Datum 14-09-2016 18:02:10

Naam: Dennis H

Titel: Member

Geplaatst op 14-09-2016 18:55

Beste Maud,

Het werkt nu nog steeds niet zoals ik het graag zie. Ik zie namelijk nog geen groen slotje in de adresbalk zoals ik bij andere sites wel zie. Hoe krijg ik dit voor elkaar?

Met vriendelijke groeten,

Dennis Holierhoek

Datum 14-09-2016 18:55:08

Naam: Naud J

Titel: Member

Geplaatst op 14-09-2016 19:55

Beste Dennis,

Dank voor je reactie.

Dit komt omdat je een afbeelding vanaf een externe site laad (imgur.com). Wat je kan doen is de afbeelding lokaal opslaan of http:// veranderen naar https:// bij de URL van imgur, imgur ondersteund namelijk HTTPS verbindingen. Daarna zal je website een groen slotje weergeven!

Fijne avond!

Datum 14-09-2016 19:55:16